Problem with DataconnectorUI2

Oct 13, 2010 at 11:57 AM

I downloaded the sample DataconnectorUI2 and converted it to a Visual Studio 2010 project and entered my Bing key.

However when I run the application I am unable to 'Drag' Pan the map with the Mouse Pointer - I get the following error from the Bing Maps control. The Map control works fine in another SL test application I have tried:

Method not found: 'Boolean Microsoft.Maps.MapControl.Core.MapMode.get_UseInertia()'.

   at Microsoft.Maps.MapControl.Core.MapInputManager.UpdateInertia(DateTime now, Boolean stoppedDragging, Boolean usedKeys)
   at Microsoft.Maps.MapControl.Core.MapInputManager.Update()
   at Microsoft.Maps.MapControl.Core.MapInputManager.StoryboardOnFrame_Completed(Object sender, EventArgs e)
   at MS.Internal.CoreInvokeHandler.InvokeEventHandler(Int32 typeIndex, Delegate handlerDelegate, Object sender, Object args)
   at MS.Internal.JoltHelper.FireEvent(IntPtr unmanagedObj, IntPtr unmanagedObjArgs, Int32 argsTypeIndex, Int32 actualArgsTypeIndex, String eventName)

Oct 13, 2010 at 2:12 PM

Update - just solved this one. Turns out that the project was somehow caching version 1.0 of the Microsoft.Maps.MapControl.Common.dll dll. Deleted it and rebuilt the project did the trick. I am using V1.0 of Bing Maps SDK.